Major outageCursor ・ September 17, 2026
Investigating service degradation — Cloud Agents and Automations
A record of the Cursor incident on September 17, 2026 (UTC): start time, duration and severity, plus current status, what to do, and alternatives.
Started
Sep 17, 2026, 03:20 PM UTC
Resolved
ongoing
Duration
21h 45m
Impact
Major outage
Other providers down at the same time
No other provider we monitor recorded an incident during this window. This appears to have been specific to Cursor.
Derived from our own archive of official status pages across 13 providers. Items lasting more than 24 hours and unresolved items are excluded, as they would misrepresent the moment.
Current status
Cursor is operating normally now. This incident has been resolved.
See current Cursor status →What you can do during an outage
Source: Cursor's official status page.
Other Cursor incidents
- Investigating service degradation — Grok BotSeptember 17, 2026
- Investigating service degradation — Grok BotSeptember 16, 2026
- Investigating service degradationSeptember 16, 2026
- Investigating service degradationSeptember 15, 2026
- Investigating Grok service degradationSeptember 14, 2026