Partial outageCursorJune 22, 2026

Investigating service degradation — Automations

A record of the Cursor incident on June 22, 2026 (Japan time): start time, duration and severity, plus current status, what to do, and alternatives.

Started
Jun 22, 2026, 01:44 PM
Resolved
Jun 22, 2026, 01:53 PM
Duration
9m
Impact
Partial outage

Current status

Cursor is operating normally now. This incident has been resolved.

See current Cursor status

What you can do during an outage

Source: Cursor's official status page.

Other Cursor incidents

  1. Elevated errors across Anthropic modelsJune 23, 2026
  2. Degraded Performance for Composer 2.5June 18, 2026
  3. Investigating service degradation — Composer 2.5June 17, 2026
  4. Elevated errors across many models on AnthropicJune 17, 2026
  5. Investigating service degradation of the Auto modelJune 16, 2026