Partial outageCursor ・ May 21, 2026
Degraded Performance for Opus 4.7
A record of the Cursor incident on May 21, 2026 (Japan time): start time, duration and severity, plus current status, what to do, and alternatives.
Started
May 21, 2026, 12:08 AM
Resolved
May 21, 2026, 12:26 AM
Duration
18m
Impact
Partial outage
Current status
Cursor is operating normally now. This incident has been resolved.
See current Cursor status →What you can do during an outage
Source: Cursor's official status page.
Other Cursor incidents
- Degraded Performance for Agent SessionsJune 3, 2026
- Cloud Agents degradationMay 30, 2026
- Composer 2.5 Fast degradationMay 28, 2026
- Degraded Performance for Composer 2May 27, 2026
- Investigating service degradation for Composer 2.5May 27, 2026